Pkgcheck Warnings

  • All Versions
    • RedundantVersion
      slot(1.0) keywords are overshadowed by versions: 1.20.6, 1.22.11
    • OutdatedBlocker
      outdated blocker DEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • PotentialStable
      slot(1.0), stabled arches: [ amd64, arm, arm64, ppc, ppc64, x86 ], potentials: [ ~hppa, ~sparc ]
    • RedundantVersion
      slot(1.0) keywords are overshadowed by version: 1.22.11
    • OutdatedBlocker
      outdated blocker DEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 25, 44, 62
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 22, 25, 44, 62
    • UnstableOnly
      for arches: [ hppa, sparc ], all versions are unstable: [ 1.20.5, 1.20.6, 1.22.11 ]
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 25, 44, 62
  • 1.22.11
    • PotentialStable
      slot(1.0), stabled arches: [ amd64, arm, arm64, ppc, ppc64, x86 ], potentials: [ ~hppa, ~sparc ]
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 22, 25, 44, 62
  • 1.20.6
    • RedundantVersion
      slot(1.0) keywords are overshadowed by version: 1.22.11
    • OutdatedBlocker
      outdated blocker DEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 25, 44, 62
  • 1.20.5
    • RedundantVersion
      slot(1.0) keywords are overshadowed by versions: 1.20.6, 1.22.11
    • OutdatedBlocker
      outdated blocker DEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • OutdatedBlocker
      outdated blocker RDEPEND="!<media-libs/gst-plugins-bad-1.15.0:1.0": last match removed 3.17 years ago
    • MissingVersionedVirtualPerlDependency
      missing version restriction for virtual perl: 'virtual/perl-JSON-PP'
    • ExcessiveLineLength
      excessive line length (over 120 characters) on lines: 16, 17, 18, 20, 25, 44, 62

Pkgcheck is used regularly to generate QA reports. Pkgcheck is a pkgcore-based QA utility for ebuild repos.